CONNECTIVITY

Your wearable is compatible with Android™ and iOS smartphones, specifically with Android OS 4.4 or higher, iOS 8.2 / iPhone® 5 and above. All devices have Bluetooth® 4.1 Low Energy and Wi-Fi 802.11 b/g/n. Q FAQ